The Line-Following Mini-Tank

Questions and Comments on All Projects
ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

The Line-Following Mini-Tank

Postby ThePyroElectro » Sat Sep 11, 2010 3:26 am

Line-Following Mini-Tank Project Write-up

This is a custom designed line follower that uses the standard IR Emitter/Phototransistor to detect different colors for following a black line.



Questions & Comments?

miskozee
Newbie Pyro
Posts: 2
Joined: Fri Dec 03, 2010 7:03 am

Postby miskozee » Fri Dec 03, 2010 7:22 am

Please post full large size images of the pictures on the Hardware Page of this project on main Page.

Can we use common 3 Volts DC motors for running the tank?

Plz reply as soon as possible as I have selected this project for my course.....plzzzzz

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Sun Dec 05, 2010 9:05 am

Hi,

3v common would work fine. I would have to do quite a bit of digging to find the original pictures. Do you have any specific questions about this?

As long as you follow the schematic and breadboard it out, you should do just fine.

miskozee
Newbie Pyro
Posts: 2
Joined: Fri Dec 03, 2010 7:03 am

Postby miskozee » Sun Dec 05, 2010 3:57 pm

Hi,

3v common would work fine. I would have to do quite a bit of digging to find the original pictures. Do you have any specific questions about this?

As long as you follow the schematic and breadboard it out, you should do just fine.


Thanks for ur reply...!!

I have few further questions about the schematic. You had used two types of grounds. Both are the same....?

Plus what does the TIP120 transistors do? Amplify the power or voltage...?

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Mon Dec 06, 2010 9:25 am

All grounds are connected to the same common ground.

The TIP120 is a power transistor. The motors will want to draw many mili-amps of current so you need a non-standard transistor that will allow say...200 to 500 ma of current to pass through.

You can substitute this with probably any other power transistor you have.

To get a better understanding of what I'm talking about. Try the circuit with normal transistors, after running the system for about 5-10 seconds one of the transistors will get very hot or just die, because so much current is trying to pass through.

keiji313
Newbie Pyro
Posts: 3
Joined: Tue Aug 02, 2011 3:59 pm

HELP!!

Postby keiji313 » Tue Aug 02, 2011 4:09 pm

hi, i'm new here, so let me tell you my problem, we had a project at school about line followers and i searched the net and found your website, so i used your mini-tank schematic, but as i finished assembling the circuits and test it it worked, the only problem is the sensor won't work and as for the receiver it only has dim light almost nothing..what could be the problem? can you help me out with this??

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Tue Aug 02, 2011 4:51 pm

Hi Keiji313,

You will not be able to see the IR LED Emitter shine light, nor the phototransistor. They will be invisible to your eye. If you use a digital camera and take a picture or video of the tank while turned on, you will be able to see the infrared light.

It sounds like the sensor is not triggering the 2nd motor to turn on when black is sensed. Make sure the IR LED or Phototransistor are not connected backwards and that all your wires are connecting properly.

To test the sensor. Place the tank on a white sheet of paper. The tank should only move in one direction. Next, place the tank on a black sheet of paper. The tank should only move in the opposite direction. These are the results you are looking for.

If you can provide a better description of your problem and/or pictures/video I could better help you troubleshoot your problems.

keiji313
Newbie Pyro
Posts: 3
Joined: Tue Aug 02, 2011 3:59 pm

Hi Pyro

Postby keiji313 » Thu Aug 04, 2011 5:36 pm

Yes, 2nd motor is not triggering when i tested it with black color, i was thinking maybe I bought wrong IR LED and phototransistor, (is this possible?) or maybe i connected them wrong to the transistors..because i'm quite confused with the transistor's pins, especially for the TIP 120,

and one more thing, do trimmers could be a problem on this, is it ok if i use 5k potentiometer?

Sorry for the trouble, i'm new in this kind of stuff..XD

as for the pictures and videos i'll post em tommorow, because my line follower is at my school locker..

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Fri Aug 05, 2011 4:06 pm

2n2222:

Image


TIP120:

Image


C = Collector
B=Base
E = Emitter

All the transistors are NPN type (the arrow on pin 3 points away from the transistor). A potentiometer is the same as a trimmer // trimpot.

If you have some transistors backwards, the circuit will not work properly.

jeet
Newbie Pyro
Posts: 2
Joined: Sun Sep 04, 2011 2:12 pm

battery of line following mini tank

Postby jeet » Sun Sep 04, 2011 2:31 pm

Can I use 2*AA (2*1.5v) battery instead off polymer lithium -ion battery :?:

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Sun Sep 04, 2011 3:01 pm

Jeet,

Yes, 2*AA will work the same as the battery I used.

jeet
Newbie Pyro
Posts: 2
Joined: Sun Sep 04, 2011 2:12 pm

Gearbox

Postby jeet » Mon Sep 05, 2011 6:24 am

Can I use General two geared motor instead off tamiya gearbox kit,else from where can i get this? :?

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Mon Sep 05, 2011 7:44 pm

Hi,

As long as the motor is rated for 3v, it will work.
Jameco sells some of the Tamiya kits.

ravi verma
Newbie Pyro
Posts: 1
Joined: Mon Sep 26, 2011 11:48 am

Postby ravi verma » Mon Sep 26, 2011 11:53 am

i'm confused about the batteries to be used because you are showing 3 volt battery in diagram and writing 9volt battery in description please help me out of this.
please specify the rpm of motors

ThePyroElectro
PyroElectro Admin
Posts: 1181
Joined: Mon Nov 12, 2007 9:24 pm
Location: Earth
Contact:

Postby ThePyroElectro » Mon Sep 26, 2011 5:03 pm

Hi,

The battery I used was 3.7v Lithium Polymer. 2 AA batteries (1.5v each) would be ok too!

I'll change the list, sorry for the confusion!


Return to “Projects”

Who is online

Users browsing this forum: No registered users and 1 guest